eCos Home

RedBoot Home


About eCos

Supported Hardware

Downloading and Installation

Documentation

FAQ

Mailing lists

Problems

Licensing

Anonymous CVS

Contributions and Third Party Projects

eCos
(Category) (Category) eCos FAQ : (Category) Got Problems? : (Category) Toolchain build problems :
Toolchain build problems specific to Linux/Unix hosts
This section is about toolchain build problems that are only relevant for Linux or other Unix hosts.
Subcategories:

Answers in this category:
(Answer) RPM package requirements
(Answer) Toolchain build problems on other Unix systems
(Answer) Build problems on Alpha systems
(Answer) Build problems on Solaris systems

(Answer) (Category) eCos FAQ : (Category) Got Problems? : (Category) Toolchain build problems : (Category) Toolchain build problems specific to Linux/Unix hosts :
RPM package requirements

If you have installed only a minimal Linux system then some libraries may be missing. The most likely candidates are the ncurses and ncurses-devel packages, and it will be necessary to install these first. You must also have the glibc-devel package installed, although that is normally the case.


(Answer) (Category) eCos FAQ : (Category) Got Problems? : (Category) Toolchain build problems : (Category) Toolchain build problems specific to Linux/Unix hosts :
Toolchain build problems on other Unix systems

Officially Red Hat Linux is the only supported host Unix system for use with eCos, but in practice it is possible to build the tools on other systems as well. As on all systems care has to be taken care with the position of . in your PATH. In addition you will need to have a reasonable set of existing tools on your Unix machine before you can build a cross-compiler. A good starting point is the gcc compiler.


(Answer) (Category) eCos FAQ : (Category) Got Problems? : (Category) Toolchain build problems : (Category) Toolchain build problems specific to Linux/Unix hosts :
Build problems on Alpha systems

It has been reported that egcs-1.1.2 is not capable of building the eCos host-side tools (ecosconfig, etc.). Alpha users should use at least gcc 2.95.2 to compile these tools.


(Answer) (Category) eCos FAQ : (Category) Got Problems? : (Category) Toolchain build problems : (Category) Toolchain build problems specific to Linux/Unix hosts :
Build problems on Solaris systems

Two problems are occasionally encountered on Solaris systems. One of these relates to the admin command. Another involves termio although this is believed to be fixed in recent tools sources. Solutions to these problems are available via the mailing list archives.


Next: (Category) Toolchain build problems specific to Windows hosts
This document is: http://ecos.sourceware.org/fom/ecos?file=54
[Search] [Appearance] [Show Top Category Only]
This is a Faq-O-Matic 2.719.

Send any queries about the contents of this FAQ to the ecos-discuss mailing list
Send any operational queries about this FAQ to the eCos maintainers