This is the mail archive of the ecos-bugs@sourceware.org mailing list for the eCos project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

[Issue 1000891] New: Bug in redboot\current\src\flash_load.c file


https://bugzilla.ecoscentric.com/show_bug.cgi?id=1000891

           Summary: Bug in redboot\current\src\flash_load.c file
           Product: eCos
           Version: unknown
          Platform: Other (please specify)
        OS/Version: Nios II
            Status: UNCONFIRMED
          Severity: minor
          Priority: low
         Component: RedBoot
        AssignedTo: gary@mlbassoc.com
        ReportedBy: lroux@adeneo.eu
         QAContact: ecos-bugs@ecos.sourceware.org
             Class: Advice Request


I have noticed that the function flash_load_write is calling twice the
flash_read function, like this:
flash_read(flash_buffer, current_flash_page, flash_block_size, &err_addr);

with flash_buffer in RAM and current_flash_page in Flash.


The prototype of flash_read is:
int flash_read(void *flash_base, void *ram_base, int len, void **err_address)


Thus, the flash_read function should be called like this :
flash_read(current_flash_page, flash_buffer, flash_block_size, &err_addr);

-- 
Configure issuemail: https://bugzilla.ecoscentric.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the issue.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]