This is the mail archive of the mailing list for the eCos project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

[Bug 1001502] Make ip6_init2() visible globally to allow method ofdisabling ipv6 support at runtime.

Please do not reply to this email. Use the web interface provided at:

--- Comment #13 from Grant Edwards <> 2012-03-09 23:00:05 GMT ---
(In reply to comment #12)
> (In reply to comment #9)
> > I've tried several times over the years to get the right tools
> > installed and set up to build the docs, but I've never been
> > successful, I installed openjade this morning and then did some
> > googling with the doc build errors I saw, but didn't get very far.
> I wrote a memo for myself (but this is a debian-centric way). Copy that
> memo here.
> The eCos documentation writes itself in SGML format. To generate
> documentation in HTML form you need to have the James Clark's DSSL
> Engine (jade) and modular DocBook DSSSL stylesheets for print and HTML.
> So, on Debian/Ubuntu, you have to install
>   % sudo apt-get install jade docbook docbook-dsssl

Ah!  The dsssl part was one thing I was missing.  FWIW on Gentoo, the
packages you need are:


The "jade" package on Gentoo is a "FIPA-compliant Java Agent
Development Environment" (whatever that is).

> Create new directory, e.g. /tmp/build, go there and type
>   % $ECOS_REPOSITORY/../doc/sgml/makemakefile
>   % make html

That works -- though I find HTML documents that are chopped up into
hundreds and hundreds of tiny pieces to be rather useless.  You can't
skim throgh the document and it's not possible to search for
something.  It's good enough for verifying changes to the SGML though,
so that's something.

I don't suppose there's any way to build the document as a single

> To generate eCos documents in PDF form you need pdfjadeTex package, it
> is a version of TeX that can create PDF files as well as DVI files.
> Install jatetex package
>   % sudo apt-get install jadetex
> and make PDF file
>   % make pdfa4

I've got jadetex installed, but doing "make pdfa4" or "make pdfletter"
doesn't produce a pdf file, just a .tex file.

  $ make pdfa4
  jade -o ecos-ref-a4.tex -t tex -V tex-backend  -d
../ecos-working/doc/sgml/../../pa [...]
  jade:ecos-ref.sgml:56:9:Q: length of name must not exceed NAMELEN (44)
  jade:ecos-ref.sgml:217:1:Q: length of name must not exceed NAMELEN (44)
  make: *** [ecos-ref-a4.pdf] Error 1

  $ ls -l *.tex
  -rw-r--r-- 1 grante users 8043272 Mar  9 16:37 ecos-ref-a4.tex

Running "pdfjadetex ecos-ref-a4.tex" fails due to TeX capacity being exceeded:

  ! TeX capacity exceeded, sorry [number of strings=37193].

I tried increasing the max_strings for pdfjadetex by a factor of 6 to
500000, but it didn't make any difference.

Running jadetex instead of pdfjadetex exits with the same error, but it does
produce a .dvi file.  But, running dvipdf on that dvi file fails because

  GPL Ghostscript 9.04: ERROR: A pdfmark destination page 311 points beyond the
last page 310.

I'm now officially giving up on building eCos docs for I think the
fifth time...

Configure bugmail:
------- You are receiving this mail because: -------
You are on the CC list for the bug.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]