This is the mail archive of the mailing list for the eCos project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

[Bug 1001707] New: Compile Errors with 64bit RHE6.4

Please do not reply to this email. Use the web interface provided at:

           Summary: Compile Errors with 64bit RHE6.4
           Product: eCos
           Version: CVS
          Platform: All
        OS/Version: HostOS: Linux
            Status: UNCONFIRMED
          Severity: normal
          Priority: low
         Component: ConfigTool
             Class: Advice Request

Compiling the ConfigTool on 64bit RHE6.4 produces errors. The errors are all
related to 64bit file handles and pointers that can't automatically cast to 32

To work around the problem, I have forced with a cast like this:

(0xFFFF & (long)myVariable)

I have not fully tested that this will work in all case. Files with this
problem are:

eCosSerial, eCosSocket, eCosTestDownloadFilter, eCosTrace, packagesdlg,
propertywin, and TestResource

There is also a problem compiling wxGTK-2.8.8 that can be solved by using this
configure command:

../configure --with-subdirs --disable-shared --disable-sockets --prefix

Using --with-subdirs makes gizmo make files so you can compile it. Compiling it
will not copy the resulting lib file, so you have to do that by hand.

There is also a problem compiling ConfigTool related to includes. By editing
the makefile.gnu file in wxwin to the following, it will compile.

  -I$(TCLDIR)/include \
  -I /opt/wxGTK-2.8.8/include/wx-2.8 \
  -I /home/mike/Documents/wxGTK-2.8.8/contrib/include \
  -I$(INSTALLDIR)/../include \
  -I$(INSTALLDIR)/include \
  -I$(ECOSSRCDIR)/tools/configtool/common/common \
  -I$(ECOSSRCDIR)/tools/Utils/common \
  -I$(ECOSSRCDIR)/tools/ecostest/common \
EXTRALDFLAGS=-L$(TCLDIR)/lib -L$(INSTALLDIR)/lib -L/opt/ecos/ecos-3.0/lib -lcdl
-lcyginfra -ltcl

These can probably be handled on the command line or in a better way, but at
least this hack demonstrates the problem. Not the extra include paths, and the
path to the ecos lib in EXTRALDFLAGS.

All other problems were solved with yum. I tried to compile against the latest
wxGTK, and that was such a mess that I gave up and used the 2.8.8 download.

If I encounter any crashes or misbehavior in the ConfigTool I can report back
and add to this bug.

Configure bugmail:
------- You are receiving this mail because: -------
You are the assignee for the bug.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]