This is the mail archive of the ecos-bugs@sourceware.org mailing list for the eCos project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

[Bug 1001789] Null pointer in snmp_send_trap and byte orderinconsistency


Please do not reply to this email, use the link below.

http://bugs.ecos.sourceware.org/show_bug.cgi?id=1001789

John Dallaway <john@dallaway.org.uk> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|UNCONFIRMED                 |NEEDINFO
                 CC|                            |john@dallaway.org.uk
     Ever confirmed|0                           |1

--- Comment #1 from John Dallaway <john@dallaway.org.uk> ---
(In reply to comment #0)

> The next problem is an inconsistency in IP representation handling. This
> code below works because it calls htonl(...) before
> snap_trap_dst_ip_set(...), which has another htonl(...) call. Most of the
> lwip takes an address in the form returned by IP4_ADDR(...). This
> inconsistency lead to some debug time trying to figure out why it did not
> work.

Ref: http://savannah.nongnu.org/bugs/?29256

It looks like this issue was fixed upstream as part of the following commit:

http://git.savannah.gnu.org/cgit/lwip.git/commit/?id=d0f1c552e2146825d011f106672698244eea01dc

Mike, can you prepare an equivalent fix for the eCos lwIP sources?

-- 
You are receiving this mail because:
You are the assignee for the bug.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]