This is the mail archive of the mailing list for the eCos project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

[Bug 1001901] Add CAN support for Olimex olpcl2294 board

Please do not reply to this email, use the link below.

--- Comment #2 from Sergei Gavrikov <> ---
Hi Uwe,

I tried to compile CAN driver for LPC-L2294-1M (with patches applied):

  % ecosconfig new olpcl2294
  % ecosconfig add can
  In file included from devs/can/arm/lpc2xxx/current/src/can_lpc2xxx.c:723:0:
  devs/can/arm/lpc2xxx/current/src/can_accfilt_lpc2xxx.c: In function
  devs/can/arm/lpc2xxx/current/src/can_accfilt_lpc2xxx.c:774:68: error:
'lpc2xxx_global_can_info_t' has no member named 'init_cnt'
  make[1]: *** [src/can_lpc2xxx.o.d] Error 1
  make: *** [build] Error 2

It looks like that with CYGINT_IO_CAN_CHANNELS == 1, can_lpc2xxx.c
cannot be compiled.

FYI: I get the same error for LPC-E2294 with such a configuration

  cdl_configuration eCos {
      template    default ;
      package CYGPKG_IO_CAN current ;
  cdl_component CYGPKG_DEVS_CAN_LPC2XXX_CAN1 {
      user_value 0
  cdl_component CYGPKG_DEVS_CAN_LPC2XXX_CAN2 {
      user_value 0
  cdl_component CYGPKG_DEVS_CAN_LPC2XXX_CAN3 {
      user_value 0

Therefore, the error was not entered with the patch.  Could you, please,
look on the LPC2XXX CAN code? Thank you.


You are receiving this mail because:
You are the assignee for the bug.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]