This is the mail archive of the mailing list for the eCos project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Insight 5.1 i386-elf-gdb Cygwin startup problem

At 13:49 13/02/2002 +0000, Jonathan Larmour wrote:
>Pete Barrie wrote:
> >
> > Latest Insight release for x86  V5.1
> >
> > i386-elf-gdb _was_ working under Cygwin
> >
> > I think I ran gdb  (/usr/bin/gdb) a few times
> >
> > Now when I run i386-elf-gdb it bombs out
> > without starting UI . Goes back to command
> > prompt. No error messages.
> >
> > However,
> > i386-elf-gdb -nx    starts up OK (-nx : Do not read gdb.ini file)
> >
> > I take it this is an gdb.ini file issue?
> > Maybe a file over-write?
> > I'm not sure how to fix this.
> > I rebuilt complete Insight system - no change in behaviour.
> >
> > Any thoughts.
>If you run
>i386-elf-gdb -nw
>it may be more likely to tell you the problem it had. Maybe :-)

Tried that already Jonathan. No clues I'm afraid.
i386-elf-gdb -nw  works fine
i386-elf-gdb -nx  works fine
i386-elf-gdb  exits silently after loading.

Thanks anyway for your time


>Red Hat, Rustat House, Clifton Road, Cambridge, UK. Tel: +44 (1223) 271062
>Maybe this world is another planet's Hell -Aldous Huxley || Opinions==mine

Before posting, please read the FAQ:
and search the list archive:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]