This is the mail archive of the mailing list for the eCos project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

PPP Stack

(BTW, sorry if I've sent this repeatedly--having problems w/ Ximian

I'm not sure if anyone else had this problem, but I thought that I would
pass along the information.  I was using the eCos PPP stack in conjunction
with an EB40A, and I was able to establish a link w/ a Linux peer flawlessly
(btw, thanks for the cool stack--I was able to create a program in Linux and
have it immediately work in eCos!); however, when trying to connect to
another device (in particular, a Kyocera 1xRTT module), a link never
occurred (i.e., the Kyocera module never even tried to respond to PPP
packets sent).  Further inspection showed that the eCos stack did not send
out an initial "flag sequence", and I assume the module timed out before the
next frame was sent (i.e., wasn't able the use the previous ending "flag
sequence" as the beginning "flag sequence" of the new frame).  I modified
the code in "pppasyncstart" such that the "flag sequence (0x7e)" is sent
before every frame, and this seemed to worked great for my application;
however, I'm not sure this would be best for all users since a "NULL frame"
would possibly have to be digested by all possible peers.  Anyhow, let me
know if this is the right way to go.  Thanks for the great operating system.

John Paul King

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]