This is the mail archive of the
libc-alpha@sources.redhat.com
mailing list for the glibc project.
Re: [PATCH] add ppc64 specific code
- From: Roland McGrath <roland at redhat dot com>
- To: "Steve Munroe" <sjmunroe at us dot ibm dot com>
- Cc: Geoff Keating <geoffk at redhat dot com>, libc-alpha at sources dot redhat dot com
- Date: Tue, 17 Sep 2002 13:21:53 -0700
- Subject: Re: [PATCH] add ppc64 specific code
> Actually this was copied from powerpc32, which still uses the
> dl_reloc_overflow symbol dl-machine.c, but that is OK because it is static?
Yes, the names of static functions don't matter (except their readability).
> So in the case of copying files into new directory (while slight
> modifications), when should I include whole copywrite pedigree and when
> should I just specify the release year?
It's always safe to keep the old copyright years. I sometimes remove old
ones and just insert this year when adding a new file, but usually not when
there is a great deal copied from the old file. Of course, when there is a
whole lot copied it's often a sign that the plan is wrong and something
should be done to share more code and copy less.