This is the mail archive of the
libc-alpha@sourceware.org
mailing list for the glibc project.
Re: [PATCH] Prevent warning in pldd
- From: "Carlos O'Donell" <carlos at systemhalted dot org>
- To: Marek Polacek <polacek at redhat dot com>
- Cc: libc-alpha at sourceware dot org
- Date: Mon, 16 Apr 2012 14:18:22 -0400
- Subject: Re: [PATCH] Prevent warning in pldd
- References: <20120416170447.GO2941@redhat.com>
On Mon, Apr 16, 2012 at 1:04 PM, Marek Polacek <polacek@redhat.com> wrote:
> After introducing static_assert in assert.h, GCC now issues a warning:
>
> pldd-xx.c:26:0: warning: "static_assert" redefined [enabled by default]
> ../assert/assert.h:119:0: note: this is the location of the previous definition
>
> We can circumvent this by e.g. renaming "static_assert" in pldd-xx.c
> to something that won't clash with assert.h. ?Regtested on x86_64-linux,
> builded with both GCC 4.6.3 and 4.8, ok for trunk?
>
> 2012-04-16 ?Marek Polacek ?<polacek@redhat.com>
>
> ? ? ? ?* elf/pldd-xx.c: Rename static_assert to pldd_assert.
>
Right, ISO C11 has taken static_assert, so we need to use another name.
This looks good to me.
Cheers,
Carlos.