This is the mail archive of the libc-alpha@sourceware.org mailing list for the glibc project.
| Index Nav: | [Date Index] [Subject Index] [Author Index] [Thread Index] | |
|---|---|---|
| Message Nav: | [Date Prev] [Date Next] | [Thread Prev] [Thread Next] |
| Other format: | [Raw text] | |
Hi Mike
Thanks for review comments
All comments are integared and changes resent for review
https://sourceware.org/ml/libc-alpha/2017-07/msg00201.html
Thanks and Regards,
Akhilesh Kumar
--------- Original Message ---------
Sender : Mike FABIAN <mfabian@redhat.com>
Date : 2017-07-05 20:54 (GMT+5:30)
Title : Re: [PATCH 2/2] Added new Fiji Hindi locales.
Akhilesh Kumar <akhilesh.k@samsung.com> さんはかきました:
> [BZ #21694]
> Added Fiji Hindi language locale same as Hindi for Fiji.
>
> Signed-off-by: Akhilesh Kumar <akhilesh.k@samsung.com>
> ---
> locale/iso-639.def | 1 +
> localedata/SUPPORTED | 1 +
> localedata/locales/hif_FJ | 138 ++++++++++++++++++++++++++++++++++++++++++++++
> 3 files changed, 140 insertions(+)
> create mode 100644 localedata/locales/hif_FJ
>
> diff --git a/locale/iso-639.def b/locale/iso-639.def
> index 5e8c048..4a3801c 100644
> --- a/locale/iso-639.def
> +++ b/locale/iso-639.def
> @@ -150,6 +150,7 @@ DEFINE_LANGUAGE_CODE3 ("Ewondo", ewo, ewo)
> DEFINE_LANGUAGE_CODE3 ("Fang", fan, fan)
> DEFINE_LANGUAGE_CODE3 ("Fanti", fat, fat)
> DEFINE_LANGUAGE_CODE ("Faroese", fo, fao, fao)
> +DEFINE_LANGUAGE_CODE3 ("FijiHindi", hif, hif)
^ space missing
> DEFINE_LANGUAGE_CODE ("Fijian", fj, fij, fij)
> DEFINE_LANGUAGE_CODE3 ("Filipino; Pilipino", fil, fil)
> DEFINE_LANGUAGE_CODE ("Finnish", fi, fin, fin)
[...]
> diff --git a/localedata/locales/hif_FJ b/localedata/locales/hif_FJ
> new file mode 100644
> index 0000000..a2fca5b
> --- /dev/null
> +++ b/localedata/locales/hif_FJ
> @@ -0,0 +1,138 @@
> +comment_char %
> +escape_char /
> +
> +% Fiji Hindi language locale same as Hindi for Fiji.
> +% Contributed by Akhilesh Kumar <akhilesh.k@samsung.com>.
> +% Wrods translated from https://en.wikipedia.org/wiki/Fiji_Hindi
^Words
> +
> +LC_IDENTIFICATION
> +title "Fiji Hinda language locale for Fiji"
^i
[...]
[...]
> +LC_TIME
> +% Full month names
> +copy "hi_IN"
> +END LC_TIME
> +%
You copy the month names here from hi_IN, which are in Devanagari
script. Therefore, LC_MESSAGES and LC_NAME should also copy
hi_IN and not en_US.
I am not sure which script is most commonly used for Fiji Hindi.
https://hif.wikipedia.org/wiki/Fiji seems to use Latin script.
But https://en.wikipedia.org/wiki/Fiji_Hindi lists “Devanagari” first
under “Writing System”.
If we want this locale to use Devanagari script, we can use copy "hi_IN"
as I suggested above.
But if we want this locale to use Latin script, we should create
new LC_TIME, LC_MESSAGES, and LC_NAME sections.
What do we want here?
[...]
> +LC_MEASUREMENT
> +measurement 1
> +END LC_MEASUREMENT
> +
> +LC_MESSAGES
> +% fix me
> +copy "en_US"
> +END LC_MESSAGES
copy hi_IN here instead of en_US
> +LC_NAME
> +% fix me
> +copy "en_US"
> +END LC_NAME
copy hi_IN here instead of en_US
> +LC_ADDRESS
> +% http://www.bitboost.com/ref/international-address-formats/fiji/
> +% %n%s%l%c
> +postal_fmt "<U0025><U006E><U0025><U0073><U0025><U006C><U0025><U0063>"
After reading
http://www.bitboost.com/ref/international-address-formats/fiji/ ;,
I think this is more correct:
+% %a%N%h%t%s%N%l%N%T%c
+postal_fmt "<U0025><U0061><U0025><U004E><U0025><U0068><U0025><U0074><U0025><U0073><U0025><U004E><U0025><U006C><U0025><U004E><U0025><U0054><U0025><U0063>"
> +% Fiji
> +country_name "<U0046><U0069><U006A><U0069>"
> +% No code
> +country_post ""
> +% http://laendercode.net/en/2-letter-list.html
> +% FJ
> +country_ab2 "<U0046><U004A>"
> +% FJI
> +% http://laendercode.net/en/countries.html
> +country_ab3 "<U0046><U004A><U0049>"
> +country_car "<U0046><U004A><U0049>"
> +country_num 242
> +% http://www.nationsonline.org/oneworld/international-calling-codes.htm
The last comment is in the wrong section, should be in LC_TELEPHONE.
> +% Fiji Hindi
> +% https://en.wikipedia.org/wiki/Fiji_Hindi
> +lang_name "<U0046><U0069><U006A><U0069><U0020><U0048><U0069><U006E><U0064><U0069>"
lang_name should contain the language endonym, i.e. the name of the
language in that language.
So when using Devanagari script it should be
+% फ़िजी बात
+lang_name "<U092B><U093C><U093F><U091C><U0940><U0020><U092C><U093E><U0924>"
Or, when using Latin script it should be "Fiji Baat", see
https://en.wikipedia.org/wiki/Fiji_Hindi
> +% tp
> +% Fix Me
> +% lang_ab "<U0068><U0069><U0066>"
> +% hif
> +lang_term "<U0068><U0069><U0066>"
Maybe add empty lang_ab and lang_lib for clarity:
+% iso-639-1 ""
+lang_ab ""
+% iso-639-3 hif
lang_term "<U0068><U0069><U0066>"
+% iso-639-2 ""
+lang_lib ""
> +END LC_ADDRESS
> +
> +LC_TELEPHONE
> +% https://www.howtocallabroad.com/fiji/
> +% +%c ;%l
> +tel_int_fmt "<U002B><U0025><U0063><U0020><U003B><U0025><U006C>"
Reading the URL makes me think the “;” is not needed, i.e. this should be:
+% +%c %l
+tel_int_fmt "<U002B><U0025><U0063><U0020><U0025><U006C>"
> +% 00
> +int_select "<U0030><U0030>"
> +% 679
> +int_prefix "<U0036><U0037><U0039>"
> +END LC_TELEPHON
^E is missing
Attached is a patch with the changes I suggest.
--
Mike FABIAN <mfabian@redhat.com>
Attachment:
0001-hif_FJ-fix-whitespace-and-typos-for-LC_MESSAGES-and-.patch
Description: Binary data
| Index Nav: | [Date Index] [Subject Index] [Author Index] [Thread Index] | |
|---|---|---|
| Message Nav: | [Date Prev] [Date Next] | [Thread Prev] [Thread Next] |