This is the mail archive of the libc-alpha@sourceware.org mailing list for the glibc project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Put CPU-related tunables into a unique namespace?


Should we use an arch namespace for CPU-related tunables?

e.g.

glibc.tune.x86.*
glibc.tune.aarch64.*
glibc.tune.power.*

We currently have:

glibc.tune.
	.hwcaps
	.cached_memopt
	.cpu

Which all look like they are "generic", but .hwcaps is
x86 only, .cached_memopt is ppc only, and .cpu is aarch64
only.

At least HJ has been using x86_* as a name prefix. Which
is another alternative.

My preference is a unique namespace to let the machine
maintainers add whatever they want in that namespace without
collisions between CPUs.

Thoughts?

-- 
Cheers,
Carlos.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]