This is the mail archive of the
libc-alpha@sourceware.org
mailing list for the glibc project.
Re: [PATCH v5 1/5] strftime: Add missing uses of L_ macro, etc. [BZ #23758]
- From: TAMUKI Shoichi <tamuki at linet dot gr dot jp>
- To: Rafal Luzynski <digitalfreak at lingonborough dot com>, libc-alpha at sourceware dot org
- Cc: Siddhesh Poyarekar <siddhesh at gotplt dot org>
- Date: Thu, 10 Jan 2019 09:43:05 +0900
- Subject: Re: [PATCH v5 1/5] strftime: Add missing uses of L_ macro, etc. [BZ #23758]
- References: <553127895.95059.1547028145705@poczta.nazwa.pl>
Hello Rafal,
From: Rafal Luzynski <digitalfreak@lingonborough.com>
Subject: Re: [PATCH v5 1/5] strftime: Add missing uses of L_ macro, etc. [BZ #23758]
Date: Wed, 9 Jan 2019 11:02:25 +0100 (CET)
> 1. Please remove any reference to [BZ #23758] from this patch
> because it is not related with the bug. The changes are minor
> and not visible for the users therefore they don't need any
> Bugzilla report, documentation, etc.
OK. I will do that as an independent patch.
> 2. Regarding the subject of this email, which is also the first
> line of the commit message, I would write something like this:
>
> "strftime: Consequently use the "L_" macro with character literals."
>
> As always, I am not a native speaker so other people may provide
> better hints.
Thank you.
> > At first, make an unrelated changes for the consistency.
>
> If it is the part of the commit message then something like:
>
> "Make unrelated changes for the consistency."
>
> (The core problem is that "an" is incorrect for plural numbers.)
Thank you. Also, "At first" is also incorrect, should be "First" (or
"First of all"). But I will not add any of them this time because of
an independent patch.
> > ChangeLog:
> >
> > [BZ #23758]
> > * time/strftime_l.c (__strftime_internal): Add missing uses of L_
> > macro, also add a missing space after the cast of _NL_CURRENT.
>
> Good but again, Bugzilla mention should be removed and "missing
> uses" seems incorrect to me, "Add "L_" macros" or "Use "L_" macros"
> is sufficient and seems correct to me.
OK. I will correct in the next patch.
Regards,
TAMUKI Shoichi