This is the mail archive of the libc-alpha@sourceware.org mailing list for the glibc project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [PATCH v2 3/4] Refactor sigcontextinfo.h



On 20/08/2019 14:19, Florian Weimer wrote:
> * Adhemerval Zanella:
> 
>> diff --git a/sysdeps/unix/sysv/linux/tst-sigcontextinfo-get_pc.c b/sysdeps/unix/sysv/linux/tst-sigcontextinfo-get_pc.c
>> new file mode 100644
>> index 0000000000..60a4c6b8f4
>> --- /dev/null
>> +++ b/sysdeps/unix/sysv/linux/tst-sigcontextinfo-get_pc.c
> 
> I think the test should be called tst-sigcontext_get_pc, to match the
> inline function name.

Ack, I changed it locally.

> 
>> +/* This file defines macros to access the content of the sigcontext element
>> +   passed up by the signal handler.  */
>> +#include <sigcontextinfo.h>
> 
> The comment is outdated, maybe we should just drop it.

Ack, I changed it locally.

> 
> Thanks,
> Florian
> 


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]