This is the mail archive of the
libc-alpha@sourceware.org
mailing list for the glibc project.
Rename RWF_WRITE_LIFE_NOT_SET to RWH_WRITE_LIFE_NOT_SET following Linux 5.5
- From: Joseph Myers <joseph at codesourcery dot com>
- To: <libc-alpha at sourceware dot org>
- Date: Wed, 12 Feb 2020 00:44:24 +0000
- Subject: Rename RWF_WRITE_LIFE_NOT_SET to RWH_WRITE_LIFE_NOT_SET following Linux 5.5
- Ironport-sdr: 75doiDQKZpPav0aSh3CtzcBrdFKbLrald7xgEaokjSSAYtcdj2kCL37X3W0dn9EGQDB/jyuzvh Npv0uudjZL20xlfkDXiO3a+NMbbHyuwx2bJnhy+mNo7zoErl/m8Id7w8jFeldxcMH2+EJ1bYC1 xnzgIppzD+ovI8IRiGhVh5gsIJF8jS6p3BrMnHZULjpbipiPdRP2eVJPCpjHpQAFtQsayinKsd SkaXC3zIjI70A3RpJOObV5q26HL7/opd2YBMlsPQv8XxEA5C2mtapbU1iSB4aUt6FMreJaaZCr 8pI=
- Ironport-sdr: CV3tiLdZswDhEJD4AsfiIhaxshPP8dakAINDey5Xsv23fK2glgY4lBrTd8arVYfpFcQzsjU/SG cWeJ5pdM81zQr16kvSSgg9jGf3giNw2fOSjpXJc3SlrjUCvSL4GftVt9f5tsCSvbtNptOL7qa0 1RjAQR5XMpqXeRS6LbRjxmAPlgIoZhEkIA8cH2J7sLl5K886ofJR7uqXfGSyrkEkOiuechLmSu 8zxqpnLRrgi7F6wqlhB8iYEMqvrg3RRIGg3sbNEWfN1e2SfR8UnkmWsfOj81P8rddrneJJEoCF JnA=
Linux 5.5 renames RWF_WRITE_LIFE_NOT_SET to RWH_WRITE_LIFE_NOT_SET,
with the old name kept as an alias. This patch makes the
corresponding change in glibc.
Tested for x86_64.
diff --git a/sysdeps/unix/sysv/linux/bits/fcntl-linux.h b/sysdeps/unix/sysv/linux/bits/fcntl-linux.h
index 07a889d683..b06488a847 100644
--- a/sysdeps/unix/sysv/linux/bits/fcntl-linux.h
+++ b/sysdeps/unix/sysv/linux/bits/fcntl-linux.h
@@ -290,7 +290,8 @@ struct f_owner_ex
#ifdef __USE_GNU
/* Hint values for F_{GET,SET}_RW_HINT. */
-# define RWF_WRITE_LIFE_NOT_SET 0
+# define RWH_WRITE_LIFE_NOT_SET 0
+# define RWF_WRITE_LIFE_NOT_SET RWH_WRITE_LIFE_NOT_SET
# define RWH_WRITE_LIFE_NONE 1
# define RWH_WRITE_LIFE_SHORT 2
# define RWH_WRITE_LIFE_MEDIUM 3
--
Joseph S. Myers
joseph@codesourcery.com