This is the mail archive of the
libc-alpha@sourceware.org
mailing list for the glibc project.
Re: [PATCH 3/7] ldbl-128ibm-compat: Add tests for IBM long double functions
- From: Joseph Myers <joseph at codesourcery dot com>
- To: "Paul E. Murphy" <murphyp at linux dot vnet dot ibm dot com>
- Cc: <libc-alpha at sourceware dot org>
- Date: Fri, 14 Feb 2020 17:31:02 +0000
- Subject: Re: [PATCH 3/7] ldbl-128ibm-compat: Add tests for IBM long double functions
- Ironport-sdr: Qiiz6WWn1pEuDFvV/mUh3RrdsXlUfBoWl7n2D+tn19C880N2HXatLyW/R+JpuaSNCtOjr1uhTF ID/SkagqhIY1bw4an83Jt/Oe8YkNxPCWwodCUwjAAoEQocMYwBRX+6KjBQYflByUWiOYwFM/VS TOh9t4KUA9h7PteXv5coKOqa/9mmGlAvZ4ji4JhnUOykf0PWjNEORda3IWALRwzd33qncPWTUL Rg8sKTohY60TiTL/KeMqQLHch6QKb2kfC0X0+CqI9OWMd6W4Es0AUxKkLUFR4xsig1pCUXFpG9 GOc=
- Ironport-sdr: xBvsqKqyFIj9JflNcKlqppx7+Y2q8yujxhAfmZgJ+yjq7LMU8b65A9S9B7TJhMhYGkI7XB83Bf lDvqiArL81aqGxFyKAM9trR4smvRx+R7XyuTzUW1OxKj/oYg+pgoWyQFjgRa6B2TsS2U3C+Sdz EAJ2LfgFt3ZaaknhAzh65se7GI9/7gjGd5Vd7shDQ69ta4GQ3tlo65bvd0kzu9cGpidudfFusg uX4YnFDwlg5Y48pYOSmCD3Bc3Qg2KrO957WYiIDrbLiRgSwTFxALLL96vJ0czjuV0d17Rl5Y66 REY=
- References: <20200214161051.32579-1-murphyp@linux.vnet.ibm.com> <20200214161051.32579-4-murphyp@linux.vnet.ibm.com>
On Fri, 14 Feb 2020, Paul E. Murphy wrote:
> diff --git a/math/test-float128.h b/math/test-float128.h
> index 8f9eec14aa..07945a090b 100644
> --- a/math/test-float128.h
> +++ b/math/test-float128.h
> @@ -28,7 +28,7 @@
> #define CFLOAT __CFLOAT128
> #define BUILD_COMPLEX(real, imag) (CMPLXF128 ((real), (imag)))
> #define PREFIX FLT128
> -#if FLT128_MANT_DIG == LDBL_MANT_DIG
> +#if __LONG_DOUBLE_USES_FLOAT128 == 0 && FLT128_MANT_DIG == LDBL_MANT_DIG
> # define TYPE_STR "ldouble"
> # define ULP_IDX ULP_LDBL
> # define ULP_I_IDX ULP_I_LDBL
This condition doesn't make sense to me, but it may be because
__LONG_DOUBLE_USES_FLOAT128 is a badly named macro. Could you please post
a patch that adds a comment to the top-level bits/long-double.h that
documents the detailed semantics of the __LONG_DOUBLE_USES_FLOAT128, and
then we can consider whether that macro needs to be given a better name?
--
Joseph S. Myers
joseph@codesourcery.com