This is the mail archive of the
systemtap@sourceware.org
mailing list for the systemtap project.
re-send: thread_info renamed to stack
- From: Wenji Huang <wenji dot huang at oracle dot com>
- To: systemtap at sourceware dot org
- Date: Fri, 03 Aug 2007 11:26:41 +0800
- Subject: re-send: thread_info renamed to stack
Hi,
There is small change for task_struct in sched.h ("since 2.6.22,
rename thread_info to stack This finally renames the thread_info field
in task structure to stack, so that the assumptions about this field are
gone and archs have more freedom about placing the thread_info
structure. "
So tapset/task.stp result in testsuite/buildok/task_test.stp failed in
kernel >=2.6.22.
Please review the patch, if there is no object, I will commit it.
Regards,
Wenji
diff -Nurp src/tapset/task.stp src.new/tapset/task.stp
--- src/tapset/task.stp 2007-08-02 22:29:18.000000000 -0400
+++ src.new/tapset/task.stp 2007-08-02 22:35:00.000000000 -0400
@@ -110,7 +110,7 @@ function task_nice:long (task:long) %{ /
// Return the scheduled cpu for the given task
function task_cpu:long (task:long)
-%( kernel_v >= "2.6.23" %?
+%( kernel_v >= "2.6.22" %?
%{ /* pure */
struct task_struct *t = (struct task_struct *)(long)THIS->task;
struct thread_info *ti = kread(&(t->stack));