This is the mail archive of the systemtap@sourceware.org mailing list for the systemtap project.
| Index Nav: | [Date Index] [Subject Index] [Author Index] [Thread Index] | |
|---|---|---|
| Message Nav: | [Date Prev] [Date Next] | [Thread Prev] [Thread Next] |
| Other format: | [Raw text] | |
On Tue, Oct 27, 2009 at 10:47:48AM +0800, Wenji Huang wrote:
> Hi,
>
Thanks for reviewing changes. I have addressed all your suggestions.
> [...]
> >+ * regs_within_kernel_stack() - check the address in the stack
> >+ * @regs: pt_regs which contains kernel stack pointer.
> >+ * @addr: address which is checked.
> >+ *
> >+ * regs_within_kenel_stack() checks @addr is within the kernel stack page(s).
> >+ * If @addr is within the kernel stack, it returns true. If not, returns false.
>
> s/regs_within_kenel_stack/regs_within_kernel_stack/
> The return type function is declared as int.
Changed it to bool. This code has been taken from x86 port. We may have
to fix this there too.
> >+ */
> >+
> >+static inline int regs_within_kernel_stack(struct pt_regs *regs,
> >+ unsigned long addr)
> >+{
> >+ return ((addr & ~(THREAD_SIZE - 1)) ==
> >+ (kernel_stack_pointer(regs) & ~(THREAD_SIZE - 1)));
> >+}
> >+
>
> Regards,
> Wenji
Please find the modified patch atached.
--
Signed-off-by: Mahesh Salgaonkar <mahesh@linux.vnet.ibm.com>
Attachment:
kprobes.ppc.patch
Description: Text document
| Index Nav: | [Date Index] [Subject Index] [Author Index] [Thread Index] | |
|---|---|---|
| Message Nav: | [Date Prev] [Date Next] | [Thread Prev] [Thread Next] |