This is the mail archive of the
libc-alpha@sourceware.org
mailing list for the glibc project.
Re: [PATCH 1/9] Use STRFMON_LDBL_IS_DBL instead of __ldbl_is_dbl.
On 12/03/2018 18:10, Zack Weinberg wrote:
> On Mon, Mar 12, 2018 at 4:36 PM, Adhemerval Zanella
> <adhemerval.zanella@linaro.org> wrote:
>>> va_start (ap, format);
>>> - res = __nldbl___vstrfmon (s, maxsize, format, ap);
>>> + ret = __vstrfmon_l_internal (s, maxsize, _NL_CURRENT_LOCALE, format, ap,
>>> + STRFMON_LDBL_IS_DBL);
>>> va_end (ap);
>>> - return res;
>>> + return ret;
>>> }
>>
>> I tend to frown at variable names changes such this case, it just add diff
>> lines without improvement in code readability.
>
> This might look pointless by itself, but as you go through the other
> patches you will see that many other functions in this file are using
> _different_ conventions for their variable names, so making the whole
> file be consistent is worthwhile IMHO. I thought it was better to
> touch each function as I was making other changes to it anyway.
>
> zw
>
Fair enough, this is more a personal preference and this is not really
a patch blocker (sorry if my ack showed this intention).