This is the mail archive of the
libc-alpha@sourceware.org
mailing list for the glibc project.
Re: [PATCH 1/2] y2038: linux: Provide __mq_timedsend_time64 implementation
- From: Andreas Schwab <schwab at suse dot de>
- To: Lukasz Majewski <lukma at denx dot de>
- Cc: Joseph Myers <joseph at codesourcery dot com>, Paul Eggert <eggert at cs dot ucla dot edu>, Adhemerval Zanella <adhemerval dot zanella at linaro dot org>, Alistair Francis <alistair23 at gmail dot com>, Alistair Francis <alistair dot francis at wdc dot com>, GNU C Library <libc-alpha at sourceware dot org>, Siddhesh Poyarekar <siddhesh at gotplt dot org>, Florian Weimer <fweimer at redhat dot com>, Florian Weimer <fw at deneb dot enyo dot de>, Zack Weinberg <zackw at panix dot com>, Carlos O'Donell <carlos at redhat dot com>
- Date: Wed, 12 Feb 2020 15:26:12 +0100
- Subject: Re: [PATCH 1/2] y2038: linux: Provide __mq_timedsend_time64 implementation
- References: <20200211165256.21848-1-lukma@denx.de> <mvmmu9pcade.fsf@suse.de> <20200212101835.2f33c2eb@jawa> <mvma75ocdkq.fsf@suse.de> <20200212113736.509a7537@jawa> <mvm5zgcccfv.fsf@suse.de> <20200212123109.3623f3d2@jawa> <mvm1rr0c9j8.fsf@suse.de> <20200212141937.1a291d02@jawa> <mvmwo8rc3jm.fsf@suse.de> <20200212151433.6788cb14@jawa>
On Feb 12 2020, Lukasz Majewski wrote:
> The question is about naming convention -
>
> include/bits/types/struct_timespec.h -> suggest that we do have here
> the "internal" re-definition of struct timespec but IMHO we do
> introduce another "internal type" - namely struct __timespec64
>
> Hence the below code shall be put to:
> include/bits/types/struct__timespec64.h
That would be ok with me either way.
Andreas.
--
Andreas Schwab, SUSE Labs, schwab@suse.de
GPG Key fingerprint = 0196 BAD8 1CE9 1970 F4BE 1748 E4D4 88E3 0EEA B9D7
"And now for something completely different."