This is the mail archive of the mailing list for the eCos project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: eCos GNU tools 4.6.2-20120125 ready for testing

Hi Sergei

Sergei Gavrikov wrote:

> I tried to build and run "thumb" tests for NXP ARM7TDMI (LPC2294) using
> corresponding RedBoot/GDB
>   ecos-v3_0-branchpoint GCC 4.3.2  most of tests failed
>   ecos AnonCVS          GCC 4.3.2  most of tests failed
>   ecos AnonCVS          GCC 4.6.2  most of tests failed
>   ecos AnonCVS          GCC 4.6.3  most of tests failed
> Thus, it looks like that GCC 4.6.2 is not point of those fails.
> BTW, I never tried ro run "thumb" blobs before on my target and maybe
> I should turn on/off more CDL options than just to force CYGHWR_THUMB
> option.

Enabling CYGHWR_THUMB should be sufficient. Be sure to "make clean" when
switching to Thumb. Also, check that the -mthumb and -mthumb-interwork
flags are definitely present during the building of your eCos tests.

> So, I agree with the said "Thumb support looks broken" at the least for
> lpc2xxx, lpc24xx variants, but, it seems to me it was broken even before
> eCos 3.0.

I have just verified that the kernel tm_basic test builds for target
eb40a (ARM7) with RAM startup and CYGHWR_THUMB. The resulting binary
runs under debug (via RedBoot) without problem. This is using the new
eCos 4.6.2-20120125 test release toolchain.

There could be a Thumb-related issue within a certain variant/platform
HAL or device driver package.

John Dallaway
eCos maintainer

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]